Version
Domino 5.x
Issue:
After performing a self-upgrade to Domino 5.x you might find that workspace syncs are failing. You might also note in the dispatcher logs the following HTTP 404 error:
WARN [d.s.r.d.s.DefaultRunManager] Failure on pull correlationId="27d03134-d6b0-45d9-bbd1-f20886bf99b3" thread="application-akka.actor.default-dispatcher-200" 2domino.common.util.http.HttpException: Code: 404, Error: Not Found, headers: Map(Play-Processing-Time -> List(2), Date -> List(Thu, 07 Jul 2022 12:51:43 GMT), Content-Type -> List(application/json), Content-Length -> List(39)), Body: {"success":false,"message":"Not Found"}
Root Cause:
Domino 5.0 has removed some configuration flags that will cause this sync failure if those flags are still present.
Resolution:
1. Go to Admin >> Advanced >> Central Config.
2. Find the following keys and click the trash can icon at the end of each row.
-
com.cerebro.domino.builder.image
-
com.cerebro.domino.computegrid.kubernetes.executor.imageName
-
com.cerebro.domino.modelmanager.harnessProxy.image
3. Click the message at the top of the page to restart the services.
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