Version/Environment (if relevant):
This applies to all versions of Domino.
Issue:
To check your workspace’s CPU and memory utilization, click on the Usage tab:
For the Usage duration, you can select either Last 30 minutes or Session Lifetime:
In some cases, a workspace could stall in the middle of a code run due to not having enough resources. This could result in errors such as:
ConnectionResetError
The previous R session was abnormally terminated due to an unexpected crash. You may have lost workspace data as a result of this crash.
Root Cause:
The hardware tier specifies the amount of resources your run will need in CPU and memory. These types of errors usually occur when the hardware tier is insufficiently sized for the task. The workspace then hits the maximum CPU and/or memory limits and can peak or spike over 100%:
Resolution:
Go to Settings > Edit Settings > Hardware Tier > switch to a larger hardware tier with more CPU and/or memory:
Notes/Information:
Generally, the user has to understand what kind of usage requirements their project has and make that assessment upfront. However, if they don’t know, they would have to run the execution (workspace, job, app) and monitor the usage. For example, they can choose the smallest or largest hardware tier, view the Usage tab for CPU and memory usage, and then iteratively adjust the size as needed. This will help them determine which hardware tier is best suited for their workspace.
Related articles:
- What does CPU utilization greater than 100% indicate?
- How to view the resource usage of workspaces, jobs, and apps
If switching to a larger hardware tier doesn’t resolve the issue, feel free to reach out to Domino Support and submit a ticket.
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