Issue:
Performing a file sync after making file changes results in either a "Push failed: Changes failed to be pushed to the Domino file system." or "Pull failed: Changes failed to be pulled from the Domino file system."
However, viewing the Setup Log does not provide any logs to identify what failed in the sync.
Root Cause:
The cause of the issue is still being investigated; however, there is a workaround for identifying what is causing the Push/Pull failed error to occur.
Resolution:
1. While opening your workspace, open your browser developer tools (In this example, Chrome) by going to More Tools > Developer Tools > Network.
2. Click on the WS button
3. Refresh the page which shows the WebSocket for the page. Click on the WebSocket.
4. Click on the tab Messages.
5. Click Sync to Domino, Sync All Changes, or Pull on the workspace to generate the error.
6. You will see a list of requests generated from the sync. Click on the one that says "FailedFileSynchronizationEvent".
7. The field "defaultMessage:" provides the log that explains why the sync failed.
In this case, there is a core.1 file that is causing this error to occur.
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