Version/Environment (if relevant):
This could apply to any version of Domino Data Lab if the project is installing the python-domino library without specifying a version of that library.
Workspace or job fails with errors in the user log:
2022-11-02 12:06:44 : Collecting typing-extensions~=4.4.0 (from dominodatalab==1.2.0->-r /mnt/requirements.txt (line 1))
2022-11-02 12:06:44 : ERROR: Could not find a version that satisfies the requirement typing-extensions~=4.4.0 (from dominodatalab==1.2.0->-r /mnt/requirements.txt (line 1)) (from versions: 3.6.2, 126.96.36.199, 3.6.5, 3.6.6, 3.7.2, 3.7.4, 188.8.131.52, 184.108.40.206, 220.127.116.11, 18.104.22.168, 22.214.171.124, 126.96.36.199, 4.0.0, 4.0.1, 4.1.0, 4.1.1)
2022-11-02 12:06:44 : ERROR: No matching distribution found for typing-extensions~=4.4.0 (from dominodatalab==1.2.0->-r /mnt/requirements.txt (line 1))
This occurs in conjunction with requirements.txt or pip installs of the dominodatalab / python-domino wrapper library without specifying version of that library.
A recent change in the python-domino library (version 1.2.0) isn't congruous with older versions of Python (recent example Python 3.6). This is a reminder that it is good practice to specify the version of the python-domino library that is compatible with your Compute Environment rather than simply installing "latest".
Rather than upgrading your version of Python in your Compute Environment you can ensure you are using a prior version of the python-domino library by modifying your pip install or requirements.txt (from pypi or github).
Via requirements.txt you can specify version, like 1.1.1:
dominodatalab == 1.1.1
Via pip you can specify version, like 1.1.1:
pip install dominodatalab==1.1.1
If fetching from github directly specify version, like 1.1.1 also:
pip install https://github.com/dominodatalab/python domino.git/archive/1.1.1.zip