Version/Environment (if relevant):
Prior to 5.4.0 the Assets page is not paginated, and can timeout depending on circumstances (specific to usage)
Issue:
Browsing the Control Center -> Assets page, can lead to a short delay followed by blank results, OR "failed to get assets", and for both you can see 502 errors in the browser's Developer Tools network tab.
or "Something went wrong."
Root Cause:
Due to mass of pertinent data a query is running longer than expected, resulting in a timeout between network layers and the component querying the data.
Resolution:
Report this to Domino Technical Support. If you have an urgent need to see this data you can try to increase a timeout value within nucleus-frontend to something larger than the 75 second default:
First backup the yaml for the frontend kubectl get deploy nucleus-frontend -n <your name space> -oyaml > fe.backup.yaml
Then edit the deploy object for nucleus-frontend.
Under here:
Containers → nucleus-frontend → Environment → DOMINO_COMMAND_OPTS
add: -Dplay.server.http.idleTimeout=120s
or 200s.
Editing the deploy will cause a rollout restart of frontends, so no downtime.
Notes/Information:
CAUTION - increasing the timeout could also keep other connections alive for longer and, in extreme circumstances, could exhaust resources. We do not predict this happening regularly but the above should be done with care and you should consider this a temporary workaround rather than long-term.
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